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LAB 18 - Tab Sheets 

This lab demonstrates the functionality built into the standardized tab sheets. It highlights the ability to quickly 
modify the sheet’s structure by adding and removing columns and dividing the sheet so that it will fit within the 
sheet border. The functionality is similar with all of the standardized tab sheets. This lab uses the 
DES_Tabulation of Surfacing.xls file for the exercises.

Chapter Objectives:

 Open and review the tab sheet instructions

 Update the Pay Item File location

 Add additional columns to the table

 Delete columns from the table

 Modify fields associated with asphalt pay items

 Add additional rows to the table

 Enter data in the new rows and columns

 Divide the main sheet into sub sheets

 Link the sub sheets to a MicroStation sheet border.

The files used in this lab are:

 C:\Projects\12345\Design\Drawings\Tabs\12345DES_Tabulation of Surfacing.xls 

 C:\Projects\12345\Design\Drawings\12345DES_TabMisc##.dgn

Lab 18.1 - Review the Tab Sheet Instructions 

1. Start Excel and Open the 12345DES_Tabulation of Surfacing.xls file from 
C:\Projects\12345\Design\Drawings\Tabs.

2. <D> the Instructions button in the upper right corner of the spreadsheet. A warning 
message is displayed. <D> OK on the message window.

3. Take a few minutes and review the instructions and then minimize or dismiss them.
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Lab 18.2 - Update the Pay Item File Location

In order for the tab sheet to function properly, it must access the Trnsport_Itemlist.csv file. The location of this 
file is specified in cell D1 of the worksheet. This exercise demonstrates how to load the Trnsport_Itemlist.csv 
file.

Notice that the text for the Pay Item File is red. This indicates that the file is not found. Without 
this file, additional pay items cannot be added. To locate the Trnsport_Itemlist.csv file:

4. <D> the Update / Browse for Pay Item File button. This displays the Update / Browse 
for Pay Item File dialog box.

5. <D> The Browse for Pay Item File button. This displays the Open dialog box.

6. Navigate to the C:\Workspace\Workspace-CDOT_V8i\Standards-Global\ directory.
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7. Highlight the Trnsport_Itemlist.csv file and <D> Open.

8. <D> the Return to Excel button in the Update / Browse for Pay Item File dialog box.

The text for the Pay Item File is now black, indicating that the Trnsport_Itemlist.csv file is 
available for use.
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Lab 18.3 - Adding a Pay Item

There are times when additional pay items need to be added after work has begun on the tabulation sheet. The 
standardized tab sheet can add and sort the additional columns, keeping the existing data in the sheet with its 
proper pay item. In this exercise, a column for removal of concrete pavement is added.

The illustration above shows the sheet before adding the column.

1. <D> the Data Entry button. This displays the Surfacing Data Entry dialog box.

2. Scroll down the list of pay items and highlight the 202-00210 Removal of Concrete 
Pavement pay item.
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3. <D> the Add Items button.

4. <D> Close to dismiss the Surfacing Data Entry dialog box.

Notice that the Removal of Concrete Pavement is now the first pay item column on the sheet. 
Also note that the data in the sheet was shifted to keep it with the proper pay item.

The illustration above shows the sheet after the new column is added.

5. Next, add pay item 411-10300 Emulsified Asphalt (Prime Coat).
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Lab 18.4 - Deleting a Pay Item

Sometimes pay items originally added to the sheet are not used. The standardized tab sheet can 
remove the specified columns and reorganize the remaining data. In this exercise, the column 
for patching asphalt is removed.

1. <D> the Data Entry button. This displays the Surfacing Data Entry dialog box.

2. <D> the Delete a Pay Item already placed in sheet button. This displays the 
Delete Item dialog box.

3. Highlight the 403-00721 Hot Mix Asphalt (Patching) (Asphalt) pay item.

4. <D> the Delete Item button.

5. <D> Close on the Delete Item and the Surfacing Data Entry dialog boxes.

Notice that the patching asphalt column is gone and the columns to the right have shifted over. 
The illustration below shows the final layout.
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Lab 18.5 - Additional Fields Associated with HMA Pay Items

Unlike concrete, asphalt pavement is laid down in a series of lifts. Each lift making up the total pavement could 
be a different thickness, width, and/or a different grade (which uses a different pay item code). In addition, the 
tab sheet can account for assumed irregularities in the paving process. These items are accounted for in the 
tabulation sheet with three fields outside of the table and a heading row within the table. 

For the exercise below, the final pavement consists of three lifts of PG 64-22 asphalt and one lift (the Top lift) 
of PG 76-28 asphalt. The existing tab sheet consists of four lifts of PG 64-22 asphalt which will be corrected in 
this exercise. An irregularity factor of 5% will be used for the Bottom lift only.

1. <D> in the Number of Lifts cell for the 403-32841 Hot Mix Asphalt (Grading SG) (100) 
(PG 64-22) pay item.

2. Use the drop down menu and select 3 from the list.

The pay item now consists of three lifts instead of four. The original Lift 2 row was deleted 
(including the data). The Lift 3 and Lift 4 rows were shifted over and renamed. The 
illustration below shows the results.
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Now change the irregularity factor for the PG 64-22 pay item. The irregularity factor for 
the PG 76-28 does not have to be changed because it is already 0.

3. <D> in cell R7. This is the% Irreg to Apply: cell for the Bottom lift of the 403-32841 Hot 
Mix Asphalt (Grading SG) (100) (PG 64-22) pay item.

4. Key in 5 and press the Tab key. The change is made in cell R7. This value is used to 
determine the total amount of material used for irregularities at the bottom of the sheet.

5. Using the Tab has moved the cursor to the U7 cell. Press the Delete key to clear this cell.

6. Tab again and Delete the contents of cell X7. The Irregularities quantity is shown at the 
bottom of the sheet in the totals area.

The width for each asphalt lift may be fixed, so that they are all the same, or they may be 
variable with each successive lift one foot wider than the lift above.
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The width for each HMA lift is based on the width of the Top lift. The values for the Top 
widths were entered prior to deleting the extra lift and were entered as Variable HMA Lift 
Widths. Notice that the data entered in the table has not been re-calculated since deleting 
the extra lift. Therefore, the bottom lift is one foot too wide. 

To correct the Bottom width:

7. <D> in cell AA15. 

Note: Changing the width of an HMA Top lift triggers a re-calculation of HMA lower lift 
widths on a row by row basis.

8. Key in 40 and press Enter.

9. Repeat step 8 for the remaining rows that contain data.

Note: Values for any column can also be entered manually. However, re-entering the 
width in the Top column ensures that all columns of HMA items using a unit of 
TONs are updated correctly.
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Important! Non-HMA quantities based on pavement widths (like Aggregate Base 
Course) are not automatically updated and must be corrected 
manually.

The next series of steps will illustrate the difference between fixed and variable lift width 
by entering additional data into rows 37 and 38.

10. Verify that cell A8 is set to Variable HMA Lift Widths.

11. <D> in cell C37 and enter 157+00 for the From station, then Tab to the next column.

12. In cell D37, key in 164+00 for the To station.

13. <D> in cell AA37. This is the cell for the Top lift of all of the HMA pay items.

14. Key in 40 for the width. Notice that the widths for each of the other HMA lifts on the row 
are automatically calculated, increasing by one foot for each lift.

15. Change cell A8 to Fixed HMA Lift Widths.

16. <D> in cell C38 and enter 164+00 for the From station, then Tab to the next column.

17. In cell D37, key in 171+00 for the To station.

18. <D> in cell AA38. This is the cell for the Top lift of all of the HMA pay items.
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19. Key in 40 for the width. Notice that the widths for each of the other HMA lifts on the row 
are populated with the same value for each lift.

Note: Category 411 pay items with a unit of GALs use the same value as the Bottom 
HMA width to calculate quantities. 

20. Copy the Thickness value down to the two new rows for each of the HMA columns.

Rows 4, 5, and 6 in the spreadsheet are reserved for the application rates of various 
materials. Although standard default values are automatically entered when a pay item is 
added to the tab sheet, these values can be changed manually. In this exercise, the 
application rate for 411-10300 Emulsified Asphalt (Prime Coat) needs to be changed from 
0.1 gallons per square yard to 0.2 gallons per square yard.

21. <D> in cell AH6.
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22. Key in 0.2 and press Enter.

Notice that the quantities in column AI automatically update to reflect the new application 
rate.

Lab 18.6 - Add Additional Data to the Sheet

Two additional rows are needed for this next exercise. 

1. <R> on the row number 39 and follow the steps in Section 2.4 of the Tabulation of 
Surfacing instructions to add two additional rows.

The next few steps will consist of entering new station extents for the last three rows, 
removing unwanted data values for Sawing Concrete pay item, and adding pay item 
quantities for Removal of Concrete Pavement, Sawing Concrete Pavement, and 11” 
Concrete Pavement

2. First, enter the station extents for the last three lines using the following data:

♦ 171+00 to 178+00

♦ 178+00 to 185+00

♦ 185+00 to 192+00

3. Next, remove the quantities for Sawing Concrete for all rows except for station 185+00 to 
192+00. <D> in cell N15. This is the first quantity cell of the sawing concrete pavement 
pay item.

4. Press the Delete key to remove the quantity.

5. <D> and hold on the little box in the lower right corner of the N15 cell.
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6. Drag down the N column to row 40 then release the mouse button. This deletes all of the 
unneeded quantities.

7. The illustration below shows the completed station columns.

The project requires 36’ of concrete sawing for the extents from Sta. 171+00 to Sta.178+00 and 
from Sta. 185+00 to Sta. 192+00.
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8. <D> in cell N39.

9. Key in a value of 36 in cell N39 and cell N41.

This completes the changes for Sawing Concrete.

Next, the Removal of Concrete Pavement quantities are added. This occurs from Sta. 171+00 to 
the end of the job. The width of the pavement being removed is 36’

10. <D> in cell I39.

11. Key in 36.

12. <D> and hold on the little box in the lower right corner of the I39 cell.

13. Drag down the I column to row 41 then release the mouse button. This adds the 36’ width 
to each row.

14. To calculate the quantity for 11” Concrete Pavement, enter 36 in cells AJ39 through AJ41.

Below is an illustration of the completed sheet.

15. Save the file.
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Lab 18.7 - Dividing the Surfacing Sheet into Sub Sheets

It the sheet is too long to fit inside the sheet border, there is a option to divide the master sheet into sub sheets 
of a specified number of data rows. When this option is selected, additional worksheets are added to the file 
that contain a part of the master sheet along with a sheet totals table. In this exercise, it was decided that 20 
rows of data was the maximum per sheet. (this number will vary based on the tab sheet being used and 
additional information that may be included in the printable sheet.)

1. In the top left portion of the tab sheet, <D> the Divide Sheet button. This displays the 
Sheet Rows dialog box.

2. Key in 20. This is the number of data rows used on each sub sheet.

3. <D> OK.

Two sub sheets (Sub Sheet 1 and Sub Sheet 2) are created along with Sub Sheet Totals.

The master sheet (Surfacing Sheet) is left intact. To re-divide the master sheet by a different 
number of rows, delete all the Sub Sheet and Sub Sheet Totals worksheets and run through the 
process again.

4. Save but do not close the file.
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Lab 18.8 - Link the Sub Sheets to a MicroStation Sheet Border

The final step in creating the tab sheet is to link the Excel file to the MicroStation sheet border. Linking allows 
the Excel file to be updated and reflect those updates in the MicroStation file. In this exercise, Sub Sheet 1 is 
linked to the sheet border file. The process is the same for the other sub sheets.

The first step in linking the spreadsheet is to prepare the MicroStation file. The miscellaneous 
tab sheet border is copied and renamed to be the surfacing tab sheet.

1. Start MicroStation and open 12345DES_TabMisc##.dgn.

2. Select File > Save As from the MicroStation menu bar.

3. Key in 12345DES_TabSurf01.dgn in the File name field.

4. <D> Save. This creates the new file and opens it.

5. Bring Excel to the front.

6. Select the Sub Sheet 1 worksheet.
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7. Highlight the entire table (cells C2 through AP29).

8. Select Edit > Copy from the Excel menu bar.

9. Bring MicroStation to the front.

10.  Select Edit > Paste Special from the menu bar. This displays the Paste Special dialog 
box.
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11. In the Paste Special dialog box, highlight Linked Microsoft Office Excel 2003 
Worksheet.

12. <D> Paste. This displays the Paste OLE Object tool settings box.

13. In the Paste OLE Object tool settings box, set the Method to By Size.

14. In the Scale field key in 8.500. This makes the text in the Excel file the proper size for the 
MicroStation file.

15. A box is connected to the cursor. This represents the size of the table that is being placed. 
Center it inside the sheet border and <D>. The file is now linked to the sheet border file.
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16. The hatching in the table indicates that the Excel file is open. Bring Excel to the front and 
close it to remove the hatching. The illustration shows the final result.

17. Close MicroStation.
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Chapter Summary:

 The tab sheets use the Trnsport_Itemlist.csv file to set the column headings for the tab 
sheet.

  The Trnsport_Itemlist.csv file is updated by ServerCop at log in or it can be manually 
updated.

 Programming that automates the layout and revision of the column headings is accessed 
through various buttons placed in the worksheet.

 Rows are added or deleted using standard Excel functionality.

 Large tab sheets can be divided to fit into multiple sheet borders.

 If the tab sheet is divided, a sheet totals table is also created.

 The tab sheets are linked to a MicroStation sheet border for printing


